Gereksinimler

Web sunucusu

phpMyAdmin’in arayüzü tamamen tarayıcınıza dayandığından bu yana, phpMyAdmin’in dosyalarını içine yüklemek için bir web sunucusuna (Apache, nginx, IIS gibi) ihtiyacınız olacak.

PHP

  • Oturum desteği, Standart PHP Kütüphanesi (SPL) uzantısı, hash, ctype, ve JSON desteği olan PHP 5.5.0 veya daha yenisine ihtiyacınız var.

  • mbstring uzantısı (bakınız mbstring) performans nedenlerinden dolayı şiddetle önerilir.

  • ZIP dosyalarının gönderiminin desteklenmesi için PHP zip uzantısına ihtiyacınız var.

  • PHP içinde JPEG’lerin (“image/jpeg: inline”) küçük resimlerini orijinal en-boy oranları ile hizada görüntülemek için GD2 desteğine ihtiyacınız var.

  • Tanımlama bilgisi kimlik doğrulaması (varsayılan) kullanılırken, openssl uzantısı şiddetle önerilir.

  • Gönderme ilerlemesi çubukları desteği için, bakınız 2.9 Gönderme ilerlemesi çubuğu görme.

  • XML ve Open Document Hesap Tablosu içe aktarma desteği için libxml uzantısına ihtiyacınız var.

  • Oturum açma sayfasında reCAPTCHA desteği için openssl uzantısına ihtiyacınız var.

  • phpMyAdmin’in en son sürümünü görüntülemeyi desteklemek için php.ini‘’ dosyanız içinde allow_url_open parametresini etkinleştirmeniz ya da curl uzantısına sahip olmanız gerekir.

Veritabanı

phpMyAdmin MySQL uyumlu veritabanlarını destekler.

  • MySQL 5.5 veya yenisi

  • MariaDB 5.5 veya daha yenisi

Web tarayıcısı

phpMyAdmin’e erişmek için tanımlama bilgileri ve JavaScript etkinleştirilmiş bir web tarayıcısına ihtiyacınız var.

JQuery 2.0 tarafından desteklenen tarayıcıya ihtiyacınız var, <https://jquery.com/browser-support/> adresine bakın.